Or call our technical support: +31852080825

Available Monday through Friday from 7AM to 3:30PM CET
Please create a ticket before calling and keep the ticket number at hand.
At the moment we are only offering support in English, so we kindly ask you to address your issue in English.
Start a new topic

Z-axis sensor not triggering when homing print bed

I pitched in with a number friends on a dual-extruder printer about 1.5-2 years ago.  The first unit we got had a shattered plate.  The replacement unit had a warped Z-axis screw (made things look like mummies).  I managed to cobble together a single working machine out of the two sets of parts and I think we successfully printed a gear before it was pretty much abandoned.

Today, I rescued the unit from a work closet and I'm trying to rehabilitate it.  I've gotten most of the setup issues sorted out, but one think I've noticed is that the Z-axis end stop sensor is active (sensor light is on), but when I send an M119 code via the Repetier Host software, it doesn't show that it's activated.  X and Y seem to be working fine.  First time I homed it, I thought it was going to shatter the base plate - fortunately I E-Stopped it before it did any damage.

23:54:13.998 : x_min:H x_max:H y_min:H y_max:H z_min:L z_max:L

Any ideas?  I can't really use it until I get this issue sorted out.



(73.3 KB)

I have a Creatr XL. 

Sending to home the Z axis it goes beyond the 0 position and collides with the print head.

Using the Repetier Host software the X and Y axis work well while the Z axis works well excluding the homing function. If I try to send the Z axis beyond the 0 position using the arrows it correctly stops when it reaches the 0. But if I press the Z Home button it goes crashing!

Since the machine goes home with X, Y and Z axis at the beginning of any work, it is impossible to begin working.

Any idea to solve the problem? 

Thanks. Carlo

Having already reached the position (0,0,0) I've sent the M119 command and I've received the answer (L,L,L).

I sent the X and Y axis to home. Not so for the Z axis to avoid collisions...

I've resent the M119 command and I've received the answer (H,H,L).

So, I'm sure that the printer now thinks to be at the home position for the X and Y axis while it is not at home with the Z axis - even if it is at the zero position...

How can I convince my printer that zero is home and it has not to go beyond zero?

Ok.. found that Slick3r has a Start / End G-code that send a G28 command to home all the axis.

So I think that erasing that command the printjob will begin without homing.... and I should do it manually before launching the printjob.

Remains the problem that probabily my Z end stop doesn't work... 

Any idea?

Does the Z end stop light up when you try and home it. Is the Z end stop close to the metal plate to activate it.

Yes, on mine, the Z end stop sensor does light up (see attached picture on original post) when the stage is sufficiently elevated.

I don't have a datasheet on that sensor or anything - is the sensor digital or analog?  If it's analog and the Arduino input is using ADC, maybe it's not passing some threshold?  I'm totally spit-balling here - I haven't taken it apart to see how things are hooked up on the controller board and it's corresponding shield.  But, if there were a way for me to diagnose the problem, I could probably do it.



I believe that it is digital .

In mine the sensor does not light up... 

Maybe the sensor is not working correctly?    ... I remember to have seen a red light coming from it at the very beginning... I started one job without using plastic - just to verify that the machine was ok - but I stopped it before the end... then I started some other jobs at the same manner, without any problem.

After that I moved the print head using the arrows of Repetier host and when I homed the Z axis the collision happened.

Now I do not find how to make the Z end stop function...

Ok, I've tried to send the bed downward to have some space at the side of the Z end stop.

Approaching the Z end stop with a tongs I see that it lights up.     ... but when I bring the bed near it it doesn't.

It cannot be a problem with the distance of the bed plate from the sensor because the tongs where slightly far from the sensor then the bed plate.

Maybe the sensor is not able to recognize the metal of the bed plate? I don't think so because it is the one that Leapfrog used to build the printer...


The structure of the printer is not enought rigid.

I found that it is not perfectly vertical (the base of the machine is not perfectly aligned with the top).

This causes the malfunction: the metal bed plate goes up along a non-vertical line and at the top it finds itself a bit too far from the Z end stop sensor.

Now I have to find the way to bring the whole machine to remain perfectly vertical... this way I'm sure it will solve the problem.

Advise to Leapfrog: You should revise the structure of the machine providing for triangular shapes which will grant its rigidity.

Good!! I solved the problem by simply adjusting the distance of the Z end stop sensor from the metallic flange that sustains the printing bed.

Another advise to Leapfrog: write in the user manual to check the correct functionality of the Z end stop sensor before trying to do anything with the printer - just to avoid collisions.

P.S. The bolts of the sensor where loosen! The printer was brand new...     these important bolts where loosen, and so where also the screw of the side panels... hopefully a better check on the machines before sending them to the customers!

Now I have to recalibrate the printing bed to keep it at the right distance from the printing head... but I need the plastic to do this job: it'll be done in the next days, as soon as I will have the filament at home.

Nice work, Carlo.  I'll try adjusting how close the sensor is on mine as well.  

Before you made any adjustments, did the light on the Z sensor go on when the printing bed was all the way up?  How far away was the sensor before?  On mine, the light goes on, but the M119 code still shows "L"ow for the Z end stop.  Does yours show "H"igh now?

Hi Casey,

before the adjustments the Z sensor did not light up even if the bed was all the way up.

I sent the bed down and I tried to aproach the Z sensor with a metallic object and I saw the Z sensor led lighting up. So I understood that the bed plate was a bit too far from it.

I brought the bed plate to the 0 position (in Z axis) - where it had to stop - and I saw that the Z sensor did not light up.   I tried to push towards the right the top of the machine (just pushed it with my hands) and I saw that the sensor had lighted up while pushing and switched off while not pushing the top of the printer.

I do not know exactly what is the distance because I do not have a measuring instrument to take the measure... it may be 1 or 2 mm.  But it is not so important because you have to find the distance proceeding how I described before: the sensor has to be loosen and aproached to the bed plate up to when it lights up (with the bed in home position). Then you have to block it at that distance.

If the sensor doesn't light up at any distance nor aproaching it with any metallic object may be you have to change that piece... ask leapfrog for details...

Hope you'll solve the problem.



Login or Signup to post a comment

User Manual

Quick Start Guide

Installation clips
The following 3 clips will guide you through the installation process of your Creatr. By following these, you will be printing within 30 minutes. First start with unpacking the printer. Clickhere to see how you correctly pick up the printer

Part 1 of 3: Unpacking your Creatr

In this clip, you will be guided through the unpacking of a brand new Creatr. The unboxing along with the location of tie wraps which need to be removed are shown, as well as the process of a connecting the cables to the printer and computer.

Part 2 of 3: Software and configuration

In this clip, we will show you how to install the required software. The first step is to download and install the Arduino software to make it possible for your computer to connect with the printer. The next step is to download and install the Repetier Host Leapfrog software or that controlls your 3D printer. We have tried to make this as simple as possible and also provided direct downloading links per operating system.

If you are using the new Simplify 3D software you can follow all the steps except for the Repetier-Host Leapfrog installation and using explanation. Simply download the software via the purchase link and before first use a pop-up will appear showing you the Simplify 3D Quick start guide. You can also download the Quick start guide or access it from the software via help –> Quick start guide. The quick start guide will briefly explain the functions of the software so that you can start your first print.

Please select you operating system and follow the descriptions in the movie.

Operating systemWindows

The first step is to download and install the Arduino software to make it possible for your computer to connect with the printer. The next step is to download and install the newest version of the Repetier Host Leapfrog software as shown in the clip. This software allows you to convert your 3D software file [STL for example] to a printable file [G-Code] and allows you to control your printer. The Repetier Host Leapfrog software contains standard Creatr Print Profiles. Just select the extruder, the filament material as well as the color and Repetier will automatically select the ideal print temperature providing you the best print quality possible. There is also a Leapfrog support button implemented in the software. A Mac version will be available soon.

If you have followed the installation procedure, but you can’t control your Leapfrog Creatr and the “6 commands waiting” message in Repetier-Host Leapfrog won’t disappear, you have to install the 2.8.28 drivers. Please see Solution can’t connect 6 commands waiting in Repetier-Host Leapfrog how to do so.

For a more thorough description of Slic3s settings please check this guide!

Windows 8
To install the Arduino drivers on a computer with Windows 8 follow these steps after downloading the Arduino software.

- Save unsaved work and write the instructions down
[your computer will reboot into startup options screen]
- Press the Windows Key and the ‘R’ key simultaneously
- Copy the command inside the brackets
–>[ shutdown.exe /r /o /f /t 00 ] – Select ‘Troubleshoot’
- Select ‘Advanced options’
- Select ‘Startup Settings’
- Select ‘Disable Driver Signature Enforcement’
- Install driver as usual via device manager


In this clip, we will explain you how you can generate a STL file using Sketchup. We show you what to download and how to export your design in STL.

Part 3 of 3: Making your first print!

In this final clip, the process of creating your first print will be explained. This starts with removing the callibration print that is already on the print bed. How to insert the filament and operate the Repetier Host Leapfrog software is also shown, which should culminate in your first 3D Print on the Creatr!

Google sketchupHow to export STL files from Sketchup

The first step is to download and install the Arduino software to make it possible for your computer to connect with the printer. You will then need to in stall this driver for OSX to recognize the hardware.

The next step is to download the Repetier software as shown in the clip. This software allows you to convert your 3D software file [STL for example] to a printable file [G-Code] and allows you to control your printer. We have developed standard print profiles for the Creatr. Please follow the instructions below to install the print profiles for Mac [not yet included in the video]:

- Download This file
- Go to your Home Folder on Mac and select “Go to Folder” from the Go Menu en type “Library/Application Support/Slic3r/” - Unzip the file you just downloaded and dump the contents in the Slic3r folder, it will replace your existing settings. If you want to keep your current settings as well, take the contents from each folder and put this in the same folder in the Home/Libaray/App../Slic3r folder.

Download instructions by Deepak Dinesh Mehta For a more thorough description of Slic3s settings please check this guide!

Troubleshooting Trees

Filament Guide

  • Extrude at ~ 225o C.
  • Requires heated bed.
  • Works reasonably well without cooling.
  • Adheres best to polyimide tape.
  • Filament tolerances are usually tighter.
  • Prone to cracking, delamination, and wraping.
  • More flexible.
  • Can be bonded using adhesives or solvents(Acetone or MEK).
  • Fumes are unpleasent in enclosed areas.
  • Oil Based.
  • Extrude at ~ 180-225o C.
  • Benefits from heated bed.
  • Benefits greatly from cooling while printing.
  • Adheres well to a variety of surfaces.
  • Finer feature detail possible on a well calibrated machine.
  • Prone to curling of corners and overhangs.
  • More brittle.
  • Can be bonded using adhesives.
  • More pleasant smell when extruded.
  • Plant Based.

Demo Print Downloads

Drivers Downloads

Software Downloads

Firmware Downloads

Please request a firmware download via the Ticket System

Creatr Video Library